兼容低版本IE的JScript5.5实现

转载  2006-09-23   作者:   我要评论

作者Blog:www.coolcode.cn

IE 5.5 中的 JScript 版本是 5.5 版,它比以前版本的 JScript 中多了如数组的 push、pop、shift、unshift 方法和 encodeURI、decodeURI 等一些重要的函数。而这些增加的内容在目前其他浏览器(如 Moziila/Firefox 和 Opera)上也同样支持。因此目前开发网站一般对于 IE 浏览器只能兼容到 5.5 版,而对于更低版本的 IE(如 IE 5、IE 4 等),则不再去考虑了。虽然这些低版本的 IE 浏览器目前已经不是主流,但如果能够不需要修改现有代码就能够兼容它们的话,倒是也可以考虑。因此我做了这个兼容低版本 IE 的 JScript 5.5 实现。当然它不可能完全兼容 JScript 5.5,但对于最常用的一些方法,都已经实现了。

该库使用非常简单,只需要在网页的 head 部分加入:

<script type="text/javascript" src="iecompat.js"></script>
就可以了。

完全实现的:

Array 对象中: 

·push 方法
·pop 方法
·shift 方法
·unshift 方法
·splice 方法

Date 对象中: 

·toDateString 方法
·toTimeString 方法
·toLocaleDateString 方法
·toLocaleTimeString 方法
·Function 对象中: 
·apply 方法
·call 方法

Global 对象中: 

·undefined 属性
·encodeURI 方法
·encodeURIComponent 方法
·decodeURI 方法
·decodeURIComponent 方法

Number 对象中: 

·toExponential 方法
·toFixed 方法
·toPrecision 方法

对于错误处理,IE 5(JScript 5)中已经有了 try…catch 和 throw 语句,因此 decodeURI、decodeURIComponent、toExponential、toFixed、toPrecision、apply 如果出现运行期错误,在 IE 5 上会抛出跟 IE 5.5+ 中一样的错误信息,但是因为 IE 4 没有错误处理语句,如果上述函数出现运行期错误,将会返回 null。注意上面说的运行期错误,不是指上述函数实现中的错误,而是指在这些函数正常工作的情况下应该出现的错误。

其中 Function 的 apply 函数的实现参考了:
http://www.openjsan.org/doc/a/ad/adamk/Upgrade/0.04/lib/Upgrade/Function/apply.html
这段程序。

不完全实现的:

Error 对象

Object 对象中: 

·isPrototypeOf 方法
·hasOwnProperty 方法
·propertyIsEnumerable 方法

String 对象中: 

·toLocaleLowerCase 方法
·toLocaleUpperCase 方法
·localeCompare 方法

因为 IE 4 不具备错误处理语句,因此 Error 对象在 IE 4 上并不具备 IE 5 以上 Error 对象应具有的功能,因此它对于 IE 4 的实现只能保证你在访问或创建它时不会出错。

Object 中的 isPrototypeOf、hasOwnProperty 和 propertyIsEnumerable 方法只是做了模拟实现,其返回值并非总是正确。

String 对象中的 toLocaleLowerCase、toLocaleUpperCase 和 localeCompare 方法实际上并没有考虑本地字符集,但在大部分系统上它还是工作正常的。

完全没有实现的:

正则表达式对象中扩充的属性和限定符

下载: iecompat.js


[Ctrl+A 全选 注:如需引入外部Js需刷新才能执行]

如果你想测试低版本的 IE 浏览器上的效果,又没有安装低版本的 IE 浏览器,可以使用这个包:ie_all.zip 。这里面都是不需要安装的 IE,直接释放压缩包到一个目录下,就可以运行了。如果你是 win9x 系统,可以到 这里 下载 win9x 版的 standalone IE。

相关文章

最新评论