linux云主机安装pdo详细教程

转载  2017-08-26   投稿:mdxy-dxy   我要评论

这篇文章主要介绍了linux云主机安装pdo详细教程,网上搜到一个几个还算清晰的教程,但是没加说明,很多站长按照做了,中途出现错误,便不知如何解决了,这里特整理一下方便需要的朋友

最近小编需要在阿里云主机上安装pdo模块,因为现在有很多程序像phpwind、wecenter都需要开启才能安装。小编在网上找了很多教程都没有成功或者说的不详细,终于在phpwind官方论坛找到一篇还算非常不错的linux主机安装pdo教程,下面就整理给大家。

前期准备

1.首先小编用的是wdcp面板(国内非常知名的一款linux管理面板)大家可以查看:阿里云Linux主机安装WDCP管理面板
另外小编的linux系统是Centos 6.3系统。

2.准备xshell。

注意:以下紫色代码是需要在xshell中运行的,如果你也是用阿里云主机,并且wdcp面板,建议直接复制粘帖。如果不是,可以合理应变。

1.登陆xshell。随便找个临时目录,比如/home ,输入以下代码:

cd /home

2.使用wget下载php官方提供的pdo的包

wget http://pecl.php.net/get/PDO_MYSQL-1.0.2.tgz

3.解压缩

tar zxvf PDO_MYSQL-1.0.2.tgz

4.进入刚才解压的目录

cd PDO_MYSQL-1.0.2

5.用phpize为PHP添加动态扩展

/www/wdlinux/php/bin/phpize

注:到这步注意了,要根据自己服务器php的安装位置,phpize在php的安装目录的bin下面。如果执行了这个语句,提示没有phpize,说明要去安装下phpize(问百度)

6.编译

./configure --with-php-config=/www/wdlinux/php/bin/php-config --with-pdo-mysql=/www/wdlinux/mysql

这步要注意,把php的路径自己修改下。

如果没报错,如果这条语句出现错误的话,暂时不要做第7步,先看下解决方法:

configure: error: no acceptable C compiler found in $PATH

看清图中,是不是有个error

如果是这样的话则需要安装gcc :下面是安装gcc教程:

安装gcc

yum -y install gcc

但是,当我们执行这个语句后,发现又报错了

具体报错是

Error: Package: glibc-headers-2.12-1.80.el6_3.6.x86_64 (updates)
Requires: kernel-headers >= 2.2.1
Error: Package: glibc-headers-2.12-1.80.el6_3.6.x86_64 (updates)
Requires: kernel-headers

如果出现报错,那么下面是解决方法:

打开yum配置文件
vim /etc/yum.conf
找到
exclude=kernel*
改成
# exclude=kernel*
保存即可

7.make

make

8.make install

make install

这个执行完成之后,会出现

安装出错

说明已经成功了。

9.还有最后一步,有时编译的时候,系统会自动帮你做好,有时不需要自己操作
编辑/www/wdlinux/etc/php.ini文件, 在最后加入

extension=/www/wdlinux/apache_php-5.2.17/lib/php/extensions/no-debug-non-zts-20060613/pdo_mysql.so

注意:这么长的路径,需要换成自己的,第7步做完不是有个这么长串的地址的。
要是单这样加没用,在前面加个(这个不是命令,是php.ini)
 
[pdo_mysql]
extension="pdo_mysql.so" 

10.重启apache或者nginx

service httpd restart
service nginxd restart 

最后测试:phpinfo.php看看有没有pdo_mysql,光有pdo不行的

测试成功

以上就是linux云主机安装pdo教程了,再次感谢phpwind论坛,小编亲测成功!

最新评论