易语言编写登录小程序实例讲解

 更新时间:2018年11月30日 10:45:11   投稿:laozhang   我要评论
在本篇文章中小编给大家整理了关于易语言编写登录小程序的源码内容,需要的朋友们学习下。

我们首先来看下源码内容

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击

.如果真 (编辑框1.内容 = “” 或 编辑框2.内容 = “”)
  信息框 (“用户名或密码不能为空!”, 0, , )
  编辑框1.获取焦点 ()
  标签3.可视 = 假
  标签4.可视 = 假
  返回 ()

.如果真结束
.如果真 (编辑框1.内容 = “123” 且 编辑框2.内容 = “123”)
  信息框 (“登录成功!”, 0, , )
  标签3.可视 = 真

  返回 ()

.如果真结束
信息框 (“登录失败!”, 0, , )
标签3.可视 = 假
标签4.可视 = 真


.子程序 _编辑框1_按下某键, 逻辑型
.参数 键代码, 整数型
.参数 功能键状态, 整数型

.如果真 (键代码 = #回车键)

  编辑框2.获取焦点 ()

.如果真结束


.子程序 _编辑框2_按下某键, 逻辑型
.参数 键代码, 整数型
.参数 功能键状态, 整数型

.如果真 (键代码 = #回车键)
  _按钮1_被单击 ()
.如果真结束



.子程序 _标签4_反馈事件, 整数型
.参数 参数一, 整数型
.参数 参数二, 整数型

下面是代码截图:

这里写图片描述

这里写图片描述

这里写图片描述

运行结果截图:

这里写图片描述 

这里写图片描述 

这里写图片描述 

这里写图片描述 

这里写图片描述 

这里写图片描述

相关文章

  • 易语言连续赋值命令使用讲解

    易语言连续赋值命令使用讲解

    今天小编就为大家分享一篇关于易语言连续赋值命令使用讲解,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言分组框组件使用方法

    易语言分组框组件使用方法

    在本篇内容里小编给大家分享的是关于易语言分组框组件使用方法和步骤,对此有需要的朋友们可以学习下。
    2018-12-12
  • 易语言调用api实现文件拖放获取路径的代码

    易语言调用api实现文件拖放获取路径的代码

    今天小编就为大家分享一篇关于易语言调用api实现文件拖放获取路径的代码,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言枚举进程所有句柄信息的代码

    易语言枚举进程所有句柄信息的代码

    今天小编就为大家分享一篇关于易语言枚举进程所有句柄信息的代码,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言编写网页刷点击程序

    易语言编写网页刷点击程序

    在本篇内容里小编给大家分享的是关于易语言编写网页刷点击程序制作果教学,对此有兴趣的朋友们学习下。
    2019-01-01
  • 易语言声明变量的步骤讲解

    易语言声明变量的步骤讲解

    在本篇文章里小编给大家分享了关于易语言声明变量的步骤相关知识点,有需要的朋友们学习下。
    2019-01-01
  • 易语言中嵌入html直接显示方法

    易语言中嵌入html直接显示方法

    在本篇文章里小编给大家分享了关于易语言中嵌入html直接显示方法,有需要的朋友们可以学习下。
    2018-11-11
  • 易语言写内存字节集方法

    易语言写内存字节集方法

    在本篇内容中小编给大家分享的是关于易语言写内存字节集的方法步骤,需要的朋友们参考下。
    2018-12-12
  • 易语言查找文本的方法

    易语言查找文本的方法

    在本篇文章里小编给大家分享了关于易语言查找文本的方法和技巧,有需要的朋友们学习下。
    2019-01-01
  • 易语言比较两个文本ASCII码值大小

    易语言比较两个文本ASCII码值大小

    今天小编就为大家分享一篇关于易语言比较两个文本ASCII码值大小,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11

最新评论