易语言获取进程id的方法

 更新时间:2018年12月29日 14:14:16   投稿:laozhang   我要评论

在本篇内容里小编为大家分享了关于易语言获取进程id的方法和步骤,需要的朋友们可以学习下。

本文介绍如何通过易语言,来获取进程ID。(本次教程不需要用到dll和模块,十分简单)

1、启动易语言,新建“Windows窗口程序”。

2、建立一个“按钮”

3、双击“按钮”

4、放入以下代码:

.版本 2

.支持库 eAPI

.支持库 spec

.程序集 窗口程序集1

.子程序 _按钮1_被单击

.局部变量 进程信息, 进程信息, , "0"

.局部变量 n, 整数型

.局部变量 取进程ID, 整数型

进程信息 = 取系统进程列表 ()

.计次循环首 (取数组成员数 (进程信息), n)

  .如果真 (进程信息 [n].进程名称 = “e.exe”)

    取进程ID = 进程信息 [n].进程标识符

    跳出循环 ()

  .如果真结束

.计次循环尾 ()

调试输出 (取进程ID)

5、点击“运行”

6、点击“按钮”

7、进程ID就出来了

相关文章

  • 分析易语言数据类型初始值

    分析易语言数据类型初始值

    在本篇内容里小编给大家整理了关于易语言数据类型初始值的相关知识点内容,有兴趣的朋友们参考学习下。
    2018-11-11
  • 易语言防止杀毒软件误报的方法

    易语言防止杀毒软件误报的方法

    在本篇内容里小编给大家整理了关于易语言防止杀毒软件误报的方法和步骤,需要的可以学习下。
    2018-12-12
  • 易语言取文件MD5值的方法

    易语言取文件MD5值的方法

    在本篇内容中小编为大家分享了关于易语言取文件MD5值的方法以及相关知识点,需要的朋友们学习下。
    2018-12-12
  • 易语言添加模块引用的方法

    易语言添加模块引用的方法

    在本篇内容里小编给读者们分享了关于易语言添加模块引用的方法和技巧,需要的朋友们可以参加学习下。
    2018-12-12
  • 易语言取反的实际操作

    易语言取反的实际操作

    在本篇内容里小编分享给大家关于易语言取反的教学内容,对此有需要的读者们学习下。
    2018-12-12
  • 易语言是在VB6上二次开发或二次封装吗

    易语言是在VB6上二次开发或二次封装吗

    在本篇文章里我们给大家分享了关于一个网上经常被问到的问题,易语言是在VB6上二次开发或二次封装吗,我们给大家讲一下思路。
    2018-10-10
  • 易语言取执行文件名命令使用讲解

    易语言取执行文件名命令使用讲解

    今天小编就为大家分享一篇关于易语言取执行文件名命令使用讲解,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言操作注册表的细节分享

    易语言操作注册表的细节分享

    在本篇文章里我们给大家分享了易语言操作注册表的相关细节内容,有需要的朋友们可以跟着学习参考下。
    2018-11-11
  • 易语言改变列表框的排列方式

    易语言改变列表框的排列方式

    今天小编就为大家分享一篇关于易语言改变列表框的排列方式,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言程序编译脚本错误的问题解决办法

    易语言程序编译脚本错误的问题解决办法

    在本篇文章中小编给大家分享了关于易语言程序编译脚本错误的问题解决办法,对此有兴趣的朋友们可以学习下。
    2019-01-01

最新评论