易语言制作图标提取器方法

 更新时间:2019年01月02日 16:41:44   投稿:laozhang   我要评论

在本篇内容里小编为大家整理了关于易语言制作图标提取器的教程和步骤,对此有需要的朋友们可以学习下。

图标提取器网上也很多这样的工具,这里我们就用易语言自己做一个,本人也是一边学边应用,代码不一定好,只给大家参考学习用

1、我们先做好图标提取器的界面,添加两个按钮,两个编辑框,适当更改一下窗口的标题和标签说明

2、接着增加一个图片框,设置为凹入式,背景颜色为白,添加标签说明接着增加一个图片框,设置为凹入式,背景颜色为白,添加标签说明

3、接着再添加两个通用对话框,通用对话模型1类型设置为“保存文件”,通用对话框2类型设置为”打开文件“

4、界面做好了,再看代码部分,先添加两个程序集变量

5、按钮打开被单击事件下代码

.版本 2

.支持库 iext2

通用对话框2.过滤器 = “程序文件(*.exe)|*.exe”

.如果真 (通用对话框2.打开 ())

  编辑框1.内容 = 通用对话框2.文件名

  图片组 = 建空图片组 (32, 32)

  图标索引 = 提取加入图片 (图片组, 编辑框1.内容, , )

  图片框1.图片 = 取图片组图片 (图片组, 图标索引, )

.如果真结束

6、按钮保存被单击事件下代码

.版本 2

.支持库 eAPI

通用对话框1.过滤器 = “图标文件(*.ico)|*.ico)”

.如果真 (通用对话框1.打开 ())

  编辑框2.内容 = 通用对话框1.文件名 + “.ico”

.如果真结束

.如果真 (编辑框2.内容 = “”)

  信息框 (“你还没有选择要保存的目录”, #错误图标, “警告”)

.如果真结束

.如果真 (编辑框2.内容 ≠ “”)

  信息框 (“图标已保存到:” + #换行符 + 编辑框2.内容 + #换行符, #信息图标, “提示”)

  提取资源文件图标 (编辑框1.内容, 0, 编辑框2.内容, )

总结:上面就是关于易语言制作图标提取器的全部内容,感谢大家的阅读和对脚本之家的支持。

相关文章

  • 易语言求反对数命令使用讲解

    易语言求反对数命令使用讲解

    今天小编就为大家分享一篇关于易语言求反对数命令使用讲解,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言取整命令使用讲解

    易语言取整命令使用讲解

    今天小编就为大家分享一篇关于易语言取整命令使用讲解,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言改变调节器的方向

    易语言改变调节器的方向

    今天小编就为大家分享一篇关于易语言改变调节器的方向,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言通过取设备句柄命令获取指定画板的设备场景句柄

    易语言通过取设备句柄命令获取指定画板的设备场景句柄

    今天小编就为大家分享一篇关于易语言通过取设备句柄命令获取指定画板的设备场景句柄,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言API高级技巧总结

    易语言API高级技巧总结

    在本篇文章里我们给大家分享了关于易语言API高级技巧的相关知识点内容,以后需要的朋友们可以参考学习下。
    2018-11-11
  • 易语言编写视频播放器

    易语言编写视频播放器

    在本篇内容里小编给大家整理了关于易语言视频播放器编写的方法和步骤,需要的朋友们学习下。
    2018-12-12
  • 易语言中Com对象和Office之间的交互使用方法

    易语言中Com对象和Office之间的交互使用方法

    今天小编就为大家分享一篇关于易语言中Com对象和Office之间的交互使用方法,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-10-10
  • 易语言程序界面介绍

    易语言程序界面介绍

    在本篇内容里小编给大家带来一篇关于易语言程序界面的介绍内容,需要的跟着学习下。
    2018-12-12
  • 易语言设置在画板中绘图的画笔颜色

    易语言设置在画板中绘图的画笔颜色

    今天小编就为大家分享一篇关于易语言设置在画板中绘图的画笔颜色,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 详解易语言等待线程

    详解易语言等待线程

    在本文中小编给大家整理了关于易语言中等待线程的相关知识点内容,需要的朋友们参考下。
    2018-12-12

最新评论