易语言坦克大战游戏制作

 更新时间:2019年01月03日 14:21:01   投稿:laozhang   我要评论

在本篇内容里小编给大家分享的是关于易语言坦克大战游戏制作的相关步骤和教程,对此有需要的朋友们学习下。

易语言是一款可视全中文的编程语言,既然是一款编程语言,那么肯定可以编写游戏,每一种编程语言在学习编程游戏中一般都会编写一种游戏,叫坦克大战,那么最基础的用键代码移动那个坦克,那么该如何编写呢?下面我为大家讲解!

1、打开易语言,新建windows窗口程序.

2、将按钮1放在启动窗口内.

3、随便弄一张图设置成按钮的背景图片

4、在按钮1的属性下面事件中选择被某键按下

5、在按钮1的属性下面事件中选择被某键按下

开始编写,写入代码如下

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_按下某键, 逻辑型

.参数 键代码, 整数型

.参数 功能键状态, 整数型

.如果真 (键代码 = #W键)

  按钮1.顶边 = 按钮1.顶边 - 1

.如果真结束

.如果真 (键代码 = #A键)

  按钮1.左边 = 按钮1.左边 - 1

.如果真结束

.如果真 (键代码 = #S键)

  按钮1.顶边 = 按钮1.顶边 + 1

.如果真结束

.如果真 (键代码 = #D键)

  按钮1.左边 = 按钮1.左边 + 1

.如果真结束

6、点击运行,可以显示,这样一个用键代码移动的程序就编写完成了!

总结:上面就是关于坦克大战小游戏制作的过程,感谢大家的阅读和对脚本之家的支持。

相关文章

  • 易语言实现远程控制讲解

    易语言实现远程控制讲解

    在本文里我们给大家分享了关于易语言实现远程控制讲解的详细方法,需要的朋友们参考下。
    2018-11-11
  • 易语言取出当前选中项目的项目数值的方法

    易语言取出当前选中项目的项目数值的方法

    今天小编就为大家分享一篇关于易语言取出当前选中项目的项目数值的方法,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言设置在画板中绘图的画笔颜色

    易语言设置在画板中绘图的画笔颜色

    今天小编就为大家分享一篇关于易语言设置在画板中绘图的画笔颜色,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言护眼色设置教学

    易语言护眼色设置教学

    在本篇文章里小编给大家分享了关于易语言设置好看的护眼配色的教学内容,有需要的朋友们可以学习下。
    2019-01-01
  • 易语言编写截图软件教学

    易语言编写截图软件教学

    在本篇内容里小编给大家整理的是关于易语言编写截图软件教学的相关操作流程,有需要的朋友们可以学习下。
    2018-12-12
  • 详解易语言常量用法

    详解易语言常量用法

    在本文里我们给大家整理了关于易语言常量用法以及相关知识点,有兴趣的朋友们学习下。
    2019-01-01
  • 易语言防止助手探测窗口的代码

    易语言防止助手探测窗口的代码

    今天小编就为大家分享一篇关于易语言防止助手探测窗口的代码,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言基础教程之条件选择结构

    易语言基础教程之条件选择结构

    本文给大家分享的是易语言中的语言结构之中的条件选择结构的具体使用方法,非常的简单实用,有需要的小伙伴可以参考下
    2016-05-05
  • 易语言设置日期框的最小日期和最大日期来限制显示日期范围

    易语言设置日期框的最小日期和最大日期来限制显示日期范围

    今天小编就为大家分享一篇关于易语言设置日期框的最小日期和最大日期来限制显示日期范围,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言在指定路径下新建一个文件夹目录

    易语言在指定路径下新建一个文件夹目录

    今天小编就为大家分享一篇关于易语言在指定路径下新建一个文件夹目录,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11

最新评论