apache2.2和php5.2.17在windows下整合过程的错误解决方法

 更新时间:2011年08月28日 21:54:06   作者:  
照理来说apache和php的整合应该是非常简单的,apache下载windows安装版本后一路next即可完成安装,php下载解压版本后直接解压到指定目录,然后在apache的配置文件httpd.conf的最后加入如下几行即可
复制代码 代码如下:

LoadModule php5_module d:/phpdir/php5apache2_2.dll
AddType application/x-httpd-php .php

其中phpdir是你的php安装目录,根据需要换成自己的即可。做完上述配置后,打开apache,然后在apache的htdocs目录下新建index.php文件,内容如下:
复制代码 代码如下:

<?php phpinfo(); ?>

然后在浏览器中输入http://localhost/index.php就可以显示php信息了,这个是正常情况下apache和php的整合步骤和方式。

不过我最近在windows平台下整合时却发生错误(apapche是2.2.15、php是5.2.17),在apache的配置文件中加入php的模块后再打开apache报错,显示错误:The requested operation has failed!

刚开始以为是apache和php的版本兼容问题,换成php低版本和高版本后问题依旧,换apache低版本后问题依然存在,显然我这个猜测在一定程度上是错误的。后来无意间换了一个php的ThreadSafe版本,问题就神奇的消失了,因为之前一直用的是Non Thread Safe版本,原来这样也可以惹祸。即在windows平台上整合请使用php的Thread Safe版本,不要使用Non Thread Safe版本,至于为什么,不得而知!

相关文章

最新评论