易语言调用JS取随机数

 更新时间:2019年01月03日 17:12:35   投稿:laozhang   我要评论

在本篇内容中我们给大家整理了关于易语言调用JS取随机数方法的知识点教学,有需要的朋友们可以学习下。

易语言自带的取随机数,取小范围的数字还行,大了就不行了,后面的根本取不到,所以我们需要借且JS来取随机数

1、启动易语言新建一个空白的程序或者模块都可以

2、双击界面,进入代码编辑,在代码界面新建一个子程序,修改为子程序_取随机数_JS

3、让鼠标指针放在上面,按回车添加2个整数型参数,分别命名为【起始值】【终止值】

4、可以把公开勾上,这样可以复制到模块里面进行调用。第一个参数【起始值】设置为可空,如果没有传入参数,默认就是为0

5、添加其他JS代码,完成编写,纯代码在最后,直接复制到易语言界面可以直接调用

6、测试功能是否正确。OK,此代码即使是上百万上千万的随机,也能取到,不像易语言的随机取不到后面的。

纯代码为:

.版本 2

.子程序 子程序_取随机数_JS, 整数型, 公开

.参数 起始值, 整数型, 可空

.参数 终止值, 整数型

.局部变量 Js, 对象

.局部变量 结果, 整数型

CoInitialize (0) ' 初始化COM对象,多线程调用才不会失败

Js.创建 (“ScriptControl”, )

Js.写属性 (“Language”, “JScript”)

.判断开始 (起始值 = 0)

 结果 = 到整数 (Js.文本方法 (“eval”, “parseInt(Math.random()*(” + 到文本 (终止值) + “+1),10)”))

.判断 (起始值 = 1)

 结果 = 到整数 (Js.文本方法 (“eval”, “parseInt(Math.random()*” + 到文本 (终止值) + “+1)”))

.默认

 结果 = 到整数 (Js.文本方法 (“eval”, “parseInt(Math.random()*(” + 到文本 (终止值) + “-” + 到文本 (起始值) + “+1)+” + 到文本 (起始值) + “,10)”))

.判断结束

Js.清除 ()

CoUninitialize () ' 清除

返回 (结果)

相关文章

  • 解决易语言编程乱码的问题

    解决易语言编程乱码的问题

    在本篇文章中我们给大家分享了解决易语言编程乱码的问题的具体方法,对此有需要的朋友们可以学习下。
    2018-11-11
  • 易语言超级列表框双击修改内容示例

    易语言超级列表框双击修改内容示例

    今天小编就为大家分享一篇关于易语言超级列表框双击修改内容示例,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-12-12
  • 易语言编写64位程序的方法

    易语言编写64位程序的方法

    在本篇内容里小编给大家分享了关于易语言编写64位程序的方法和步骤,需要的朋友们可以参考下。
    2018-12-12
  • 易语言的优势总结

    易语言的优势总结

    在本篇内容里小编给大家整理了关于易语言的优势和特点内容,需要的朋友们参考下。
    2018-12-12
  • 易语言用正则采集百度知道的代码

    易语言用正则采集百度知道的代码

    今天小编就为大家分享一篇关于易语言用正则采集百度知道的代码,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-12-12
  • 易语言获取进程所在路径的方法

    易语言获取进程所在路径的方法

    今天小编就为大家分享一篇关于易语言获取进程所在路径的方法,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言信息框调用子程序返回结果的代码

    易语言信息框调用子程序返回结果的代码

    今天小编就为大家分享一篇关于易语言信息框调用子程序返回结果的代码,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言数组排序命令使用讲解

    易语言数组排序命令使用讲解

    今天小编就为大家分享一篇关于易语言数组排序命令使用讲解,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言实现反OD调试反复附加的代码

    易语言实现反OD调试反复附加的代码

    今天小编就为大家分享一篇关于易语言实现反OD调试反复附加的代码,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11
  • 易语言调用ESPI11.dll实现禁止指定程序访问网络的代码

    易语言调用ESPI11.dll实现禁止指定程序访问网络的代码

    今天小编就为大家分享一篇关于易语言调用ESPI11.dll实现禁止指定程序访问网络的代码,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
    2018-11-11

最新评论